Nie szkolne – Ściąga z IOS-a (CCNA 2)

PIERWSZE URUCHOMIENIE

enable
configure terminal
hostname ABC
enable secret HASŁO
line console 0
password HASŁO
login
line vty 0 4
password HASŁO
login
banner motd # WIADOMOŚĆ #

KONFIGURACJA INTERFEJSÓW

interface TYP NUMER
ip address ADRES MASKA
description OPIS
clock rate 64000 -- tylko dla serial w trybie DCE
no shutdown

ZAPIS USTAWIEŃ DO PAMIĘCI

copy running-config startup-config

WYŚWIETLANIE KONFIGURACJI

show ip route
show ip interface brief
show interfaces [INTERFEJS]

DODAWANIE TRASY STATYCZNEJ

ip route ADRES_SIECI MASKA_PODSIECI [ADRES_IP | INTERFEJS_WYJŚCIOWY [ADRES_IP]]

Dystans administracyjny

RIPv1

router rip
network SIEĆ_KLASOWA

debug ip rip
undebug ip rip

passive-interface Fast Ethernet 0/0 -- nie będą rozsyłane pakiety rip

default-information originate -- jeśli router dysponuje trasą do 0.0.0.0/0 to będzie ją rozgłaszał

redistribute static - rozgłaszanie statycznych tras

RIPv2

router rip
version 2

no auto-summary -- wymusza nie scalanie podsieci w całe sieci między routerami nie podłączonymi do tych sieci. do każdego routera przesyłane będą adresy sieci i ich maski zmiennej długości.

sieć można dodawać jak w RIPv1 - wtedy będą rozgłaszane wszystkie wydzielone z niej podsieci

EIGRP

router eigrp 1
network ADRES_SIECI

metric weights tos k1 k2 k3 k4 k5 -- zamiast kX, mnożniki

K1 - bandwidth - 1
K2 - load - 0
K3 - delay - 0
K4 - reliability - 0
K5 - reliability - 0

show ip protocols

no auto-summary

ip summary-address eigrp as-number network-address subnet-mask -- wymuszenie scalania tras

redistribute static -- rozgłaszanie tras statycznych i 0.0.0.0/0 jeśli istnieje

(w konfiguracji interfejsu)
bandwidth 64
ip bandwidth-percent eigrp 1 50
-- ustawi szybkość połączenia serial na 64 i wymusi wykorzystywanie jedynie 50% dostępnej szybkości

(dalej w konfiguracji interfejsu)
ip hello-intercal eigrp 1 60
ip hold-time eigrp 1 180
-- konfiguracja czasów

OSPF

router ospf 1
network ADRES_SIECI ODWROTNOŚĆ_MASKI_PODSIECI area 0

interface loopback0
ip address 10.1.1.1 255.255.255.255
--ustawianie router id w stary sposób

show ip protocols
show ip ospf
show ip ospf interface
show ip ospf neighbor

(w konfiguracji interfejsu)
bandwidth ILOSC_KBPS

(dalej w konfiguracji interfejsu)
ip ospf priority -- priorytet przy wybieraniu DR i BDR w sieciach bcastowych np. ethernet

default-information originate -- rozgłaszanie trasy 0.0.0.0/0

auto-cost reference-bandwidth X -- prędkość najszybszego połączenia w Mbps. przy 100, łącze 100 Mbps ma koszt 1, przy 10000, 100.

(w konfiguracji interfejsu)
ip ospf hello-interval seconds
ip ospf dead-interval seconds

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Wymagane pola są oznaczone *